import Foundation
let pattern = #"^( *[\w+-.%]+@[\w-.]+\.[A-Za-z]{2,4}( *, *)? *)+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" aa@sss.ru,aa@dd.ru , dd@ss.com,22@dd.ei "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)