re = /^( *[\w+-.%]+@[\w-.]+\.[A-Za-z]{2,4}( *, *)? *)+$/
str = ' aa@sss.ru,aa@dd.ru , dd@ss.com,22@dd.ei '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end