$re = '/^( *[\w+-.%]+@[\w-.]+\.[A-Za-z]{2,4}( *, *)? *)+$/';
$str = ' aa@sss.ru,aa@dd.ru , dd@ss.com,22@dd.ei ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);