#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w+\s+)+(?!h\S+p(s)?://)(.*)$"
Local $sString = "Domain abcd[.]xyz" & @CRLF & _
", but not " & @CRLF & _
"Bad URL h[xx]ps://abcd[.]xyz" & @CRLF & _
" or " & @CRLF & _
"Evil URL h[xx]p://stu[.]abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")