using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+\s+)+(?!h\S+p(s)?://)(.*)$";
string input = @"Domain abcd[.]xyz
, but not
Bad URL h[xx]ps://abcd[.]xyz
or
Evil URL h[xx]p://stu[.]abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}