$re = '/^(\w+\s+)+(?!h\S+p(s)?://)(.*)$/m';
$str = 'Domain abcd[.]xyz
, but not
Bad URL h[xx]ps://abcd[.]xyz
or
Evil URL h[xx]p://stu[.]abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);