import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+\\s+)+(?!h\\S+p(s)?://)(.*)$";
final String string = "Domain abcd[.]xyz\n"
+ ", but not \n"
+ "Bad URL h[xx]ps://abcd[.]xyz\n"
+ " or \n"
+ "Evil URL h[xx]p://stu[.]abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}