#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:sqlite3ErrorMsg|sqlite3MPrintf|sqlite3VdbeError)\([^;\"]+\"([^)]+)\"(?:,|\)|:)"
Local $sString = " sqlite3ErrorMsg(pParse, variable); " & @CRLF & _
" sqlite3ErrorMsg(pParse, "row value misused");" & @CRLF & _
" ){" & @CRLF & _
" sqlite3ErrorMsg(pParse, "no \"such\" function: %.*s", nId, zId);" & @CRLF & _
" pNC->nErr++;" & @CRLF & _
" }else if( wrong_num_args ){" & @CRLF & _
" sqlite3ErrorMsg(pParse,"wrong number of arguments to function %.*s()"," & @CRLF & _
" nId, zId);" & @CRLF & _
" pNC->nErr++;" & @CRLF & _
" }" & @CRLF & _
" if( pExpr->iTable<0 ){" & @CRLF & _
" sqlite3ErrorMsg(pParse," & @CRLF & _
" "second argument to likelihood must be a "" & @CRLF & _
" "constant between 0.0 and 1.0");" & @CRLF & _
" pNC->nErr++;" & @CRLF & _
" }" & @CRLF & _
" }else if( wrong_num_args ){" & @CRLF & _
" sqlite3ErrorMsg(pParse,"factory must return a cursor, not \\w+", " & @CRLF & _
" nId);" & @CRLF & _
" pNC->nErr++;" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")