# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:sqlite3ErrorMsg|sqlite3MPrintf|sqlite3VdbeError)\([^;\"]+\"([^)]+)\"(?:,|\)|:)"
test_str = (" sqlite3ErrorMsg(pParse, variable); \n"
" sqlite3ErrorMsg(pParse, \"row value misused\");\n"
" ){\n"
" sqlite3ErrorMsg(pParse, \"no \\\"such\\\" function: %.*s\", nId, zId);\n"
" pNC->nErr++;\n"
" }else if( wrong_num_args ){\n"
" sqlite3ErrorMsg(pParse,\"wrong number of arguments to function %.*s()\",\n"
" nId, zId);\n"
" pNC->nErr++;\n"
" }\n"
" if( pExpr->iTable<0 ){\n"
" sqlite3ErrorMsg(pParse,\n"
" \"second argument to likelihood must be a \"\n"
" \"constant between 0.0 and 1.0\");\n"
" pNC->nErr++;\n"
" }\n"
" }else if( wrong_num_args ){\n"
" sqlite3ErrorMsg(pParse,\"factory must return a cursor, not \\\\w+\", \n"
" nId);\n"
" pNC->nErr++;\n"
" ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.