// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:sqlite3ErrorMsg|sqlite3MPrintf|sqlite3VdbeError)\([^;\"]+\"([^)]+)\"(?:,|\)|:)"#).unwrap();
let string = " sqlite3ErrorMsg(pParse, variable);
sqlite3ErrorMsg(pParse, \"row value misused\");
){
sqlite3ErrorMsg(pParse, \"no \\\"such\\\" function: %.*s\", nId, zId);
pNC->nErr++;
}else if( wrong_num_args ){
sqlite3ErrorMsg(pParse,\"wrong number of arguments to function %.*s()\",
nId, zId);
pNC->nErr++;
}
if( pExpr->iTable<0 ){
sqlite3ErrorMsg(pParse,
\"second argument to likelihood must be a \"
\"constant between 0.0 and 1.0\");
pNC->nErr++;
}
}else if( wrong_num_args ){
sqlite3ErrorMsg(pParse,\"factory must return a cursor, not \\\\w+\",
nId);
pNC->nErr++;
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}