using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:sqlite3ErrorMsg|sqlite3MPrintf|sqlite3VdbeError)\([^;\""]+\""([^)]+)\""(?:,|\)|:)";
string input = @" sqlite3ErrorMsg(pParse, variable);
sqlite3ErrorMsg(pParse, ""row value misused"");
){
sqlite3ErrorMsg(pParse, ""no \""such\"" function: %.*s"", nId, zId);
pNC->nErr++;
}else if( wrong_num_args ){
sqlite3ErrorMsg(pParse,""wrong number of arguments to function %.*s()"",
nId, zId);
pNC->nErr++;
}
if( pExpr->iTable<0 ){
sqlite3ErrorMsg(pParse,
""second argument to likelihood must be a ""
""constant between 0.0 and 1.0"");
pNC->nErr++;
}
}else if( wrong_num_args ){
sqlite3ErrorMsg(pParse,""factory must return a cursor, not \\w+"",
nId);
pNC->nErr++;
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}