$re = '/\d(?!\d{0,2}$|\d{13}$)/m';
$str = '7108898787654351';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;