import re
regex = re.compile(r"\d(?!\d{0,2}$|\d{13}$)", flags=re.MULTILINE)
test_str = "7108898787654351"
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)