package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\"(.*)-.*\"`)
var str = `text: {abcdefgh="test-name-test-name-w2-a"} 54554654654 .654654654`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}