const regex = /.*\"(.*)-.*\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\"(.*)-.*\\"', 'gm')
const str = `text: {abcdefgh="test-name-test-name-w2-a"} 54554654654 .654654654`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}