$re = '/.*\"(.*)-.*\"/m';
$str = 'text: {abcdefgh="test-name-test-name-w2-a"} 54554654654 .654654654';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);