re = /.*\"(.*)-.*\"/m
str = 'text: {abcdefgh="test-name-test-name-w2-a"} 54554654654 .654654654'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end