#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{\s*?(?=[a-z0-9-]*[A-Z])(.+)\.(?:i|I)*\s*?\}"
Local $sString = " FIND {N-CODREM.i} wher" & @CRLF & _
" FIND {N-CODRE99.i} wher" & @CRLF & _
" FIND { N-CODREM.i } wher" & @CRLF & _
" FIND { N-CODREM.I } wher" & @CRLF & _
"e {n-codrem.i}.motcle = "VTE"" & @CRLF & _
"e {n-codre99.i}.motcle = "VTE""" & @CRLF & _
"e {n-coDRe99.i}.motcle = "VTE"" & @CRLF & _
"e {n-coDRem.i}.motcle = "VTE""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")