use strict;
my $str = ' FIND {N-CODREM.i} wher
FIND {N-CODRE99.i} wher
FIND { N-CODREM.i } wher
FIND { N-CODREM.I } wher
e {n-codrem.i}.motcle = "VTE"
e {n-codre99.i}.motcle = "VTE""
e {n-coDRe99.i}.motcle = "VTE"
e {n-coDRem.i}.motcle = "VTE"';
my $regex = qr/\{\s*?(?=[a-z0-9-]*[A-Z])(.+)\.(?:i|I)*\s*?\}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}