import re
regex = re.compile(r"\{\s*?(?=[a-z0-9-]*[A-Z])(.+)\.(?:i|I)*\s*?\}")
test_str = (" FIND {N-CODREM.i} wher\n"
" FIND {N-CODRE99.i} wher\n"
" FIND { N-CODREM.i } wher\n"
" FIND { N-CODREM.I } wher\n"
"e {n-codrem.i}.motcle = \"VTE\"\n"
"e {n-codre99.i}.motcle = \"VTE\"\"\n"
"e {n-coDRe99.i}.motcle = \"VTE\"\n"
"e {n-coDRem.i}.motcle = \"VTE\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")