import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"\\w+\":\\s\"?[^\",\\{\\}]+\"?";
final String string = "{\n"
+ " \"response\": {\n"
+ " \"first_name\": \"Степан\",\n"
+ " \"last_name\": \"Воробьёв\",\n"
+ " \"screen_name\": \"sparrowwwwww\",\n"
+ " \"sex\": 2,\n"
+ " \"relation\": 7,\n"
+ " \"bdate\": \"14.2.1995\",\n"
+ " \"bdate_visibility\": 2,\n"
+ " \"home_town\": \"Санкт-Петербург\",\n"
+ " \"country\": {\n"
+ " \"id\": 1,\n"
+ " \"title\": \"Россия\"\n"
+ " },\n"
+ " \"city\": {\n"
+ " \"id\": 2,\n"
+ " \"title\": \"Санкт-Петербург\"\n"
+ " },\n"
+ " \"status\": \"\",\n"
+ " \"phone\": \"+7 7** *** ** 92\"\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}