import Foundation
let pattern = #""\w+":\s"?[^",{}]+"?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"response": {
"first_name": "Степан",
"last_name": "Воробьёв",
"screen_name": "sparrowwwwww",
"sex": 2,
"relation": 7,
"bdate": "14.2.1995",
"bdate_visibility": 2,
"home_town": "Санкт-Петербург",
"country": {
"id": 1,
"title": "Россия"
},
"city": {
"id": 2,
"title": "Санкт-Петербург"
},
"status": "",
"phone": "+7 7** *** ** 92"
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)