# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"\w+\":\s\"?[^\",{}]+\"?"
test_str = ("{\n"
" \"response\": {\n"
" \"first_name\": \"Степан\",\n"
" \"last_name\": \"Воробьёв\",\n"
" \"screen_name\": \"sparrowwwwww\",\n"
" \"sex\": 2,\n"
" \"relation\": 7,\n"
" \"bdate\": \"14.2.1995\",\n"
" \"bdate_visibility\": 2,\n"
" \"home_town\": \"Санкт-Петербург\",\n"
" \"country\": {\n"
" \"id\": 1,\n"
" \"title\": \"Россия\"\n"
" },\n"
" \"city\": {\n"
" \"id\": 2,\n"
" \"title\": \"Санкт-Петербург\"\n"
" },\n"
" \"status\": \"\",\n"
" \"phone\": \"+7 7** *** ** 92\"\n"
" }\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.