// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"\w+":\s"?[^",{}]+"?"#).unwrap();
let string = "{
\"response\": {
\"first_name\": \"Степан\",
\"last_name\": \"Воробьёв\",
\"screen_name\": \"sparrowwwwww\",
\"sex\": 2,
\"relation\": 7,
\"bdate\": \"14.2.1995\",
\"bdate_visibility\": 2,
\"home_town\": \"Санкт-Петербург\",
\"country\": {
\"id\": 1,
\"title\": \"Россия\"
},
\"city\": {
\"id\": 2,
\"title\": \"Санкт-Петербург\"
},
\"status\": \"\",
\"phone\": \"+7 7** *** ** 92\"
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}