package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`refer.*pro(?:fessional)?\Whacker`)
var str = `referred me to this professional hacker
referred a professional hacker
referring you to a pro hacker
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}