re = /refer.*pro(?:fessional)?\Whacker/
str = 'referred me to this professional hacker
referred a professional hacker
referring you to a pro hacker
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end