// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"refer.*pro(?:fessional)?\Whacker").unwrap();
let string = "referred me to this professional hacker
referred a professional hacker
referring you to a pro hacker
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}