$re = '/refer.*pro(?:fessional)?\Whacker/';
$str = 'referred me to this professional hacker
referred a professional hacker
referring you to a pro hacker
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);