#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9]+ ?[a-zA-Z0-9]+$"
Local $sString = "asdasd sadsad" & @CRLF & _
"sadasdasdasd" & @CRLF & _
"xzcxzcxz" & @CRLF & _
"42rerfd 5432432" & @CRLF & _
"_sdasdsda" & @CRLF & _
"ASD" & @CRLF & _
"ASD90 ASDAS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")