re = /^[a-zA-Z0-9]+ ?[a-zA-Z0-9]+$/m
str = 'asdasd sadsad
sadasdasdasd
xzcxzcxz
42rerfd 5432432
_sdasdsda
ASD
ASD90 ASDAS'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end