package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9]+ ?[a-zA-Z0-9]+$`)
var str = `asdasd sadsad
sadasdasdasd
xzcxzcxz
42rerfd 5432432
_sdasdsda
ASD
ASD90 ASDAS`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}