$re = '/^[a-zA-Z0-9]+ ?[a-zA-Z0-9]+$/m';
$str = 'asdasd sadsad
sadasdasdasd
xzcxzcxz
42rerfd 5432432
_sdasdsda
ASD
ASD90 ASDAS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);