using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^DETAIL:.+?\((.+)\).+?\((.+)\) already exists.";
string input = @"ERROR: duplicate key value violates unique constraint ""uq_content_block_internal_name_store_id""
DETAIL: Key (lower(internal_name::text), store_id)=(some content block-32067683, 0c6d20a7-d843-44f3-af9c-4a2cf2a47e4c) already exists.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}