re = /^DETAIL:.+?\((.+)\).+?\((.+)\) already exists./m
str = 'ERROR: duplicate key value violates unique constraint "uq_content_block_internal_name_store_id"
DETAIL: Key (lower(internal_name::text), store_id)=(some content block-32067683, 0c6d20a7-d843-44f3-af9c-4a2cf2a47e4c) already exists.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end