package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^DETAIL:.+?\((.+)\).+?\((.+)\) already exists.`)
var str = `ERROR: duplicate key value violates unique constraint "uq_content_block_internal_name_store_id"
DETAIL: Key (lower(internal_name::text), store_id)=(some content block-32067683, 0c6d20a7-d843-44f3-af9c-4a2cf2a47e4c) already exists.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}