package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)foo\/([^\s?]*)`)
var str = `https://test.com/foo/bar
https://test.com/foo/bar?param1=test
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}