$re = '/foo\/([^\s?]*)/m';
$str = 'https://test.com/foo/bar
https://test.com/foo/bar?param1=test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);