re = /foo\/([^\s?]*)/m
str = 'https://test.com/foo/bar
https://test.com/foo/bar?param1=test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end