# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(\w+)\].+?\[\/\1\](*SKIP)(*FAIL)|&/@/gm;t' <<< "This is & short & [tag]fun & [tag2]interesting & nice[/tag2] & beautifull[/tag] & continue.
"