$re = '~\[(\w+)\].+?\[/\1\](*SKIP)(*FAIL)|&~m';
$str = 'This is & short & [tag]fun & [tag2]interesting & nice[/tag2] & beautifull[/tag] & continue.
';
$subst = "@";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;