const regex = new RegExp('\\[(\\w+)\\].+?\\[/\\1\\](*SKIP)(*FAIL)|&', 'gm')
const str = `This is & short & [tag]fun & [tag2]interesting & nice[/tag2] & beautifull[/tag] & continue.
`;
const subst = `@`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);