#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[(\w+)\].+?\[/\1\](*SKIP)(*FAIL)|&"
Local $sString = "This is & short & [tag]fun & [tag2]interesting & nice[/tag2] & beautifull[/tag] & continue." & @CRLF & _
""
Local $sSubst = "@"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)