#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?(?=\s(?:wifi\s)?\d{2,3}gb)"
Local $sString = "iphone 13 256gb - midnight" & @CRLF & _
"iphone 13 pro max 256gb - sierra blue" & @CRLF & _
"iphone 13 pro 128gb - graphite" & @CRLF & _
"galaxy tab a8 wifi 128gb - grey" & @CRLF & _
"galaxy tab a8 wifi 64gb - grey"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")