use strict;
my $str = 'iphone 13 256gb - midnight
iphone 13 pro max 256gb - sierra blue
iphone 13 pro 128gb - graphite
galaxy tab a8 wifi 128gb - grey
galaxy tab a8 wifi 64gb - grey';
my $regex = qr/^.*?(?=\s(?:wifi\s)?\d{2,3}gb)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}