import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?(?=\\s(?:wifi\\s)?\\d{2,3}gb)";
final String string = "iphone 13 256gb - midnight\n"
+ "iphone 13 pro max 256gb - sierra blue\n"
+ "iphone 13 pro 128gb - graphite\n"
+ "galaxy tab a8 wifi 128gb - grey\n"
+ "galaxy tab a8 wifi 64gb - grey";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}