import Foundation
let pattern = #"^.*?(?=\s(?:wifi\s)?\d{2,3}gb)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
iphone 13 256gb - midnight
iphone 13 pro max 256gb - sierra blue
iphone 13 pro 128gb - graphite
galaxy tab a8 wifi 128gb - grey
galaxy tab a8 wifi 64gb - grey
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)