#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[!@#$%^&+=0-9a-zA-Z]{10,16}$"
Local $sString = "ahahahgafadrdsr" & @CRLF & _
"ahahahgaf" & @CRLF & _
"ahahahgafadrdsrgaga" & @CRLF & _
"ahahahgafadrdsr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")