$re = '/^[!@#$%^&+=0-9a-zA-Z]{10,16}$/m';
$str = 'ahahahgafadrdsr
ahahahgaf
ahahahgafadrdsrgaga
ahahahgafadrdsr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);