package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[!@#$%^&+=0-9a-zA-Z]{10,16}$`)
var str = `ahahahgafadrdsr
ahahahgaf
ahahahgafadrdsrgaga
ahahahgafadrdsr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}