re = /^[!@#$%^&+=0-9a-zA-Z]{10,16}$/m
str = 'ahahahgafadrdsr
ahahahgaf
ahahahgafadrdsrgaga
ahahahgafadrdsr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end